Allgemein

configure: error: Apache httpd version 2.4.6 includes a broken mod_dav; use a newer version of httpd

Beim kompilieren von Subversion bekam ich auf einer RHEL 7.3 Kiste folgende Fehlermeldung:

configure: error: Apache httpd version 2.4.6 includes a broken mod_dav; use a newer version of httpd

Das war für mich etwas seltsam, da es auf einer anderen RHEL 7.3 Maschine problemlos funktioniert hat, aber auf der aktuellen nicht. Nach kurzem Suchen habe ich einen Unterschied festgestellt: Die Kiste, auf der ich Subversion nicht kompilieren konnte, hatte das Paket httpd-devel installiert gehabt, während die andere Maschine dies nicht hatte. Da ich die WebDAV-Funktionalität für Subversion wie auch httpd-devel nicht brauchte, konnte ich getrost das Paket deinstallieren und wieder Subversion kompilieren. Das hat dann auch funktioniert.

Quellen: