Allgemein

configure: error: Apache httpd version 2.4.6 includes a broken mod_dav; use a newer version of httpd

Beim kompilieren von Subversion bekam ich auf einer RHEL 7.3 Kiste folgende Fehlermeldung: configure: error: Apache httpd version 2.4.6 includes a broken mod_dav; use a newer version of httpd Das war für mich etwas seltsam, da es auf einer anderen RHEL 7.3 Maschine problemlos funktioniert hat, aber auf der aktuellen nicht. Nach kurzem Suchen habe… Weiterlesen configure: error: Apache httpd version 2.4.6 includes a broken mod_dav; use a newer version of httpd

Allgemein

[Jenkins] Failed to execute goal org.jenkins-ci.tools:maven-hpi-plugin:1.117:hpi

Momentan bin ich – als eine Art von Übung – dabei, eine Funktionalität in einen der Jenkins-Plugins hinzuzufügen, genauer gesagt, das Groovy-Postbuild Plugin. Mein erstes Ziel war es den Quelltext in Eclipse einzubinden und den Quelltext, so wie er zu dem Zeitpunkt war, zum Laufen zu bekommen, d.h. am Schluss sollte ich eine hpi-Datei bekommen.… Weiterlesen [Jenkins] Failed to execute goal org.jenkins-ci.tools:maven-hpi-plugin:1.117:hpi

Allgemein ·Linux

Der (static) Linking Prozess mit dem GNU Linker

In diesem Post möchte ich kurz wiedergeben, wie der Link-Algorithmus (mit statischen Bibliotheken) bei dem GNU Linker verläuft. Dabei beziehe ich mich auf http://eli.thegreenplace.net/2013/07/09/library-order-in-static-linking, wo man neben dem Link-Algorithmus auch gut verständliche Beispiele findet (wenn auch nur auf englisch), die ich hier aber nicht nochmal beschreibe. Zu wissen, wie der Link-Algorithmus funktioniert ist wichtig wenn… Weiterlesen Der (static) Linking Prozess mit dem GNU Linker

Allgemein

[Ubuntu] getdeb Repository entfernen

Um das getdeb Repository aus Ubuntus apt zu entfernen, muss man folgende Kommandos eingeben (als root): apt-get remove getdeb-repository apt purge getdeb-repository apt clean apt-get updateapt-get remove getdeb-repository apt purge getdeb-repository apt clean apt-get update Wenn man die Befehle ausgeführt hat, muss man eventuell noch im Ordner /etc/apt/sources.list.d/ nachschauen, ob es in einen der Dateien… Weiterlesen [Ubuntu] getdeb Repository entfernen

Allgemein

boost unter Windows mit Visual Studio 2015 kompilieren

Ich habe den Eindruck, dass es nicht sehr viele Seiten gibt, in der kurz und prägnant geschrieben steht, wie man eine Bibliothek gebaut, darum will ich hier etwas davon nachholen. boost unter Windows zu bauen ist relativ einfach. Voraussetzung dafür ist eine Entwicklungsumgebung / Compiler. Ich benutze in diesem Beispiel Visual Studio 2015. Zuerst wird… Weiterlesen boost unter Windows mit Visual Studio 2015 kompilieren

Allgemein

CMake unter Linux kompilieren

Wenn man Linux unter CMake kompilieren möchte, dann geht das recht einfach. Unter https://cmake.org/download/ holt man sich das Paket seiner Wahl (wo der Quelltext drin ist), entpackt dieses auf seinem Rechner. In der Kommandozeile nun in den entsprechenden Ordner wechseln und die vier Befehle eingeben: ./configure make make install cmake –version Wenn man mit dem… Weiterlesen CMake unter Linux kompilieren

Allgemein

Fehler bei Customize WP-Login: PHP Extensions Not Found: gd

Ich hatte gerade auf meinem lokalen WordPress System versucht, das Plugin Customize WP-Login zu aktivieren. Da kam folgende Fehlermeldung: Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt. Minimum System Requirements not satisfied for: Customize_WP_Login PHP Extensions Not Found: gd Die Lösung war recht einfach (unter Linux). Einfach die zwei folgenden Befehle… Weiterlesen Fehler bei Customize WP-Login: PHP Extensions Not Found: gd